You are given an array A of N integers. You will be given Q queries with two integers L and R. For each query, you need to find the sum of all elements of the array excluding the elements in the range [L, R] (both inclusive) modulo 109+7. Input The first line of the input contains an integer N, the size of the array. The second line of the input contains N integers, the elements of the array A. The third line of the input contains an integer Q. The next Q lines contain two integers L and R.
Constraints 1 <= N <= 200000 1 <= A[i] <= 1000000000 1 <= Q <= 3 1 <= L <= R <= N Output Output Q lines, each having a single integer the answer to Q-th query. Example Sample Input 4 5 3 3 1 2 2 3 4 4
Sample Output 6 11
Explanation: The array A = [5, 3, 3, 1]. First Query: Sum = 5 + 1 = 6. Second Query: Sum = 5 + 3 + 3 = 11
link:
```cpp
#include <bits/stdc++.h> // header file includes every Standard library
using namespace std;
#define sd(x) scanf("%d", &x)
#define sz(v) (int) c.size()
#define pr(v) For(i, 0, sz(v)){cout<<v[i]<<"";}cout<<endl;
#define slld(x) scanf("%lld", &x)
#define all(x) x.begin(), x.end()
#define For(i, st, en) for(int i=st;i<en;i++)
#define tr(x) for(auto it=x.begin(); it!=x.end(); it++)
#define fast std::ios::sync_with_stdio(false);cin.tie(NULL);
#define pb push_back
#define ll long long
#define ld long double
#define int long long
#define double long double
#define mp make_pair
#define F first
#define S second
typedef pair<int , int>pii;
typedef vector<int>vi;
#define pi 3.141592653589793238
const int MOD=1e9+7;
const int INF=1LL<<60;
const int N=2e5+5;
#ifdef SWAPNIL07
#define trace(...)_f(#_VA_ARGS__,_VA_ARGS)
template <typename Arg1>
void__f(const char* name, Arg1&& arg1){
cout<<name<<":"<<arg1<<endl;
}
template<typename Arg1, typename...Args>
void_f(const char*names, Arg1&&arg1, Args&&... args){
const char*comma=strchr(names+1,',');
cout.write(names, comma-names)<<":"<<arg1<<"|";__f(comma+1, args...);
}
int begtime=clock();
#define end_routine() cout<<"\n\nTimeelapsed:"<<(clock()-begtime)*1000/CLOCKS_PER_SEC<<"ms\n\n";
#else
#define endl '\n'
#define trace(...)
#define end_routine()
#endif
void solve(){
int n; cin>>n;
vector<int>a(n+1);
vector<int> pre(n+1, 0);
int tot=0;
For(i, 1, n+1){
cin>>a[i];
assert(a[i]>0LL && a[i]<=1000000000LL);
tot += a[i];
pre[i]=pre[i-1]+a[i];
}
int q;cin>>q;
while(q--){
int l, r;cin>>l>>r;
int s=tot-(pre[r]-pre[l-1]);
s %= MOD;
cout<<s<<"\n";
}
}
signed main(){
fast
#ifdef SWAPNIL07
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
#endif
int t=1;
while(t--){
solve();
}
return 0;
}
```